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1 ILIADS Key Concepts 

1.1 Introduction 

 

ILIADS is a rich client application. It is installed and executes on the user’s Mac OS-X, 

WinPC, or Linux operating system platform. ILIADS provides the user with the 

capability to locate, retrieve, and interactively process and render mapped lunar data 

products from the Lunar Mapping and Modeling Project (LMMP) servers. In addition to 

the LMMP data servers, ILIADS provides the means for the user to gain access to other 

lunar data product sources that can serve mapped lunar data products (e.g., USGS 

PIGWAD, Geosciences PDS Node, Goddard’s ILIADS data server).  

 

This Start-up Guide provides a description of some important concepts to assist the user 

in becoming familiar with the ILIADS software application. These concepts include, but 

are not necessarily limited to, the methods ILIADS uses to organize data, known as the 

workspace, how Geospatial Information Systems (GIS) categorize data and how that data 

is typically used, as well as the principal forms of internet services that GIS use to access 

data for, and present data to, the user. 

1.2 ILIADS Workspace Key Concepts 

1.2.1 Project 

A Project is a file: it is where a user stores an instance of his/her workspace. A Project file 

contains links to the user’s image and raster data, shape data (note: these terms are 

described in Section 1.3) the user may have created or imported, and bookmarks. A 

project file also stores information about the user’s current View whenever the user 

selects the “Save View” menu item. The current view is automatically saved in the user’s 

preferences along with position of windows, etc. When the user exits the ILIADS 

application, the project file is saved. Upon restarting ILIADS, the Project file is restored 

and permits the user to continue his/her work from the point where the user’s work was 

saved.  

 

1.2.2 Scene 

Every project consists of Scenes. A scene is a sub-folder of a project that will contain 

your workspace. The user can have multiple scenes in a project. A scene permits the user 

to break his/her analysis into different organizational sections. For example, if a user had 

performed a hazard analysis on two different craters, the hazard analysis can be easily 

broken up into two different scenes to make it easier to separate the specific layers and 

other information needed to perform potentially different analyses on the two craters. 

 



Goddard Space Flight Center  Rev: Nov 24, 2010 

ILIADS Quick Start Guide  Page 4 of 31 

1.2.3 Layer 

Every scene contains one or more Layers. A layer is map projected or georeferenced data 

in the form of an image, shape, or raster draped across the surface of the moon. 

 

1.3 GIS Data Key concepts 

1.3.1 Image data 

Image data is information that has been converted from sensor information and rendered 

into a human perceptible color or grayscale medium. The sensor information that was 

used to create the image is not retained. This limits the types of computations that can be 

done on image data. For example, if a user needs to perform a slope analysis, it cannot be 

done using simply a color-coded image of the topography where (for example) red 

indicates one elevartion value or range of values, blue another value or range, etc. 

Instead, the user will need to have access to a raster version of the topography since the 

raster data will contain (in this case) the elevation values (e.g., 1000 meters) associated 

with each point in the mapped image. 

 

1.3.2 Raster data  

Raster data is similar to image data, but instead of containing color imagery, it contains 

real-valued data. Raster data cannot be viewed directly; instead it needs to be color 

mapped to create a human-perceptible image. Raster data are key for performing most 

forms of analysis functions provided by ILIADS. 

 

1.3.3 Feature/Shape data 

Feature and shape data sets consist of points, lines, and polygons. They can also contain 

ancillary information – for example, a layer can contain the locations of lunar features, 

their types, sizes, and descriptions. 

 

1.4 GIS Services Key concepts 

ILIADS and all other LMMP systems (e.g., the Portal, the OnMoon server, and the Lunar 

Mapper thin client application) adhere to the use of three Open Geospatial Consortium 

(OGC) protocol standards: WMS, WCS, and WFS.  

1.4.1 Web Mapping Service (WMS)  

Web Mapping Services provide image data. 

 

1.4.2 Web Coverage Service (WCS)  

Web Coverage Services provide raster data. 
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1.4.3 Web Feature Service (WFS)  

Web Feature Services provide feature/shape data. 

 

 

2 Getting Started 

 

When you start ILIADS, you will be prompted with the following login: 

This login is for the LMMP secure data server. If you have an account with this service, 

use your NASA AUID to login. Otherwise, click “Cancel”. By clicking “Cancel”, you 

will still be able to access all datasets that are publicly available. 

 

2.1 Creating a Project 

If this is the first time you have run ILIADS: 

You will be prompted to create a new project or open an existing project. Click “create a 

new project”. This will initiate the process of creating a new project. 

 

If this is not the first time you have run ILIADS: 

Note: If this is not the first time you have run ILIADS then ILIADS will restore the state 

that it was previously in with open project(s). 

 

You will need to create a project and add a scene. 
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To create a project, in the menu bar click: 

File->New Project 

 

You are then presented with the new project dialog: 

 

Projects can be supplied with predefined scenes and layers. For this example we will 

create an empty project. 

 

Under “Categories” select “Standard”. On the right, project templates will appear. 

Select “Empty Iliads Project”. 
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The following dialog will appear: 

 

This permits you to select a project name and location to save it (typically to a folder on 

your local disk drive). This will create a new folder that is the same name as the project, 

in the location specified. “Project Folder” shows the full path as it will be created by the 

“Project Name” and “Project Location”, and is not directly editable. 

 

Choose a “Project Name” and “Project Location”, then click “Finish”. 

 

2.2 Creating a Scene 

Once a project has been created, we will need to add a scene to the project. A scene is a 

sub-folder of a project that will contain your workspace. You can have multiple scenes in 

a project. 

 

In the menu bar, click 

File->New Scene 
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The following dialog will appear: 

 

Select from “Categories” “Moon”, and then from “Scene Types”, “Moon Template”. 

Click “Next >” 
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The following dialog will appear: 

 

Here you can set the name of the scene. Items such as “Project”, “Folder”, and “Created 

Scene” are for informational purposes only and are not editable. 

Change the “Scene Name” and click finish. 
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Your view will now look like this: 

If you do not see a globe in the right, right click your Scene (shown as 

“MoonSceneDemo” above), and select “3D View”. If the window opens, but you still do 

not see a moon, see “Notes, Tips and Tricks” section at the end of the document” 

 

2.3 Adding an Image Layer 

 

Right click on your scene, which is in this example, “MoonSceneDemo”. 

Go to “New”. 
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Available options should appear as follows: 

 

Click “Tiled Image Layer...” 

 

The following dialog will appear: 
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On the right are the data sources. These are WMS or WCS services which will retrieve 

the data over the internet. Clicking on the service will reveal the data available from it. 

 

Under “Sources”, click “LmmpWmsOnMoon”. 

Under  “Layers”, click “LO and Clementine Hybrid Mosaic” 

Click “Next”. 

 

The following dialog will appear: 
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Here you can make changes to how the data is requested and processed. For this data set 

there are no required options, so click “Finish”. 
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The data will load. If you expand “MoonSceneDemo” (by clicking the “+” icon) and then 

expand “Image Layers” it will appear as follows: 

 

2.4 Adding Raster Data as a Color Mapped Image 

This requires the same steps as above, but instead we will load a raster data set that 

ILIADS will colorize. 

 

Right click on “MoonSceneDemo”. 

Go to “New”->”Tiled Image Layer” 

In the left column, “Sources”, click on “LmmpWCSTopography”. 

In the right column, “Layers”, click on “LOLA_v2”. 

Click “Next” 
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The following dialog will appear: 

Here we can change the color map. This will choose how the raster will be displayed by 

ILIADS. We will stick with “Jet” for this example” 

 

Click “Finish”. 
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ILIADS will appear as follows: 

 

 

2.5 Performing an Analysis 

In this example, we will perform a slope analysis on topography. We will select a 

topography data set that ILIADS will download and then calculate the slopes of the 

features. 

 

Right click on the scene. 

Select “New” → “Function Layer” 
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The following dialog will appear: 

 

This dialog permits you to choose the type of analysis you wish to perform. 

“XisAnalysis” (eXtraplanetary Information System Analysis) lets you select from many 

different types of analysis commonly found in GIS systems. “ImageProcessing” contains 

common image processing algorithms, and Math contains basic mathematical 

calculations. 

 

Click “XisAnalysis” from “Sources” on the left. 

From “Layers” on the right, click “Slope Magnitude”. 

Click “Next”. 
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The following dialog will appear: 

From here we will select the data set to perform the function on. 

 

Under “Sources” on the left, click on “LmmpWcsTopography” 

Under “Layers” on the right, click on “LOLA_v2”. 

Click “Next”. 
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The following dialog will appear: 

Here we can select the options for computation. There are currently no options for slope 

other than the colorization selection. Let's change things around this time. 

 

Click on the “Color Map” combo box, and select “Hot” 

Click on “Color Map Max” and change the value to “20.0”. 

 

With these colormapping settings, ILIADS will use the “Hot” color map and set it so that 

it will paint all values between 0 to 20 degrees. Limiting the range of the colormap will 

permit fine details to be seen, but will cut off values less than or greater than the max and 

min. 

 

Click “Finish”. 
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The following image will appear: 

 

To see the legend, in the combo bar above the moon, click on the color spectrum icon:  
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The legend will appear as follows: 

 

Click on the legend button again to turn it off. 

 

2.6 Adding a Shape Layer 

Shapes permit the user to add georeferenced vector drawings. There are a number of 

different shapes that can be drawn, including lines, points, path, polygons, circle, ellipses, 

squares, and rectangles. 

 

To start the drawing tool click the pencil icon above the moon view that appears as such: 

The following dialog will appear. We have added some explanatory text on the side to 

help explain different features: 
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The process to add a shape is to: 

Click the “+” tool. 

Choose the color properties of the shape using the boxes “Line” or “Points”. Clicking 

these will bring up a color chooser dialog box. 

Change the shape desired to be generated via the “Shape” combo box. 

Click “New”. 

Start drawing the shape on the globe. 

When done, click “End”. 

To add more shapes, repeat this process. 

2.7 Adding an Elevation Layer 

Elevation Layers permit a 3D perception of the lunar surface. To load a layer for 3D 

viewing.. 

 

Right click the scene. 

Go to “New” → “Elevation Model” 
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A dialog to select the data set to use for 3D perception. 

Under “Sources”, click “LmmpWcsTopography”. 

Under “Layers”, click “LOLA_v2”. 

Click “Next”. 

At the next dialog, Click “Finish”. 

 

The results of adding this layer will be demonstrated as part of the rest of the tutorial. 

 

3 Getting Around the Moon 

This section contains information on basic ILIADS methods for changing the current 

viewpoint. 

3.1 Rotating 

To rotate the moon, a motion known as “grab” is used.  

Left click on the moon to grab it, then move the mouse in the direction desired. The move 

will rotate such that the spot on the moon you have grabbed will stay under the mouse. 

 

ILIADS only loads data that is currently visible to the user. When rotating, there may be a 

delay for data to appear as ILIADS fetches new data from the server or performs an 

analysis on a function layer. 

 

3.2 Zooming 

To zoom, you will need to use the scrolling ability of your computer. The same motion 

that will scroll a page up and down will zoom in or out. On most mice, this is the middle 

button with a scroll wheel. For most MacBooks, this can be done by using two fingers to 

stroke the tracking pad up and down. On most PC laptops, stroking the trackpad on the 

far right up and down will invoke scrolling. 

 

ILIADS dynamically loads data at the current zoom level. When zooming, there may be a 

delay for data to appear as ILIADS fetches data from the server or performs an analysis. 

 

3.3 Tilting 

Tilting changes the axis at which you view the moon. Typically, as a viewer, you are 

perpendicular to the surface. Tilting changes this angle, permitting viewing of 3D 

topography. 

 

3.4 Searching 

Another possible way to traverse the moon, is to use the feature search box. This is 

located in the tool bar above the moon: 
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Type the name and click enter. Names follow the standard lunar naming conventions. 

 

4 Putting it all together - A Visit to Tycho 

Create a new Scene in the project. 

Click → File → New Scene 

In the dialog that appears, 

Under “Catagories” select “Moon”. 

Under “Scene Type” select “MoonTemplate” 

Click “Next” 

In the next dialog, change the “Scene Name” to “Tycho” 

Click “Finish” 

 

Right click on the Scene “Tycho”. 

Go to “New” → “Tiled Image Layer” 

In the following dialog, select “IliadsWmsKaguya” as the “Source”, then select “Kaguya 

Terrain Camera 10m” as the “Layer”. 

Click “Next” 

At the next dialog, click “Finish” 

 

ILIADS should appear as follows: 
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Add an elevation model. 

 

Right click the Scene “Tycho”. 

Go to “New” → “Elevation Model” 

 

A dialog to select the data set to use for 3D perception. 

Under “Sources”, click “LmmpWcsTopography”. 

Under “Layers”, click “LOLA_v2”. 

Click “Next”. 

At the next dialog, Click “Finish”. 

 

In the search bar above the moon, type “tycho” and hit enter. ILIADS will automatically 

zoom to Tycho. 

 

To see the 3D model, use the tilting mechanism. Right click and move your mouse down. 

 

Your view will appear something like this: 
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Next we will do a surface roughness analysis on the topography.  

 

Right click the Scene “Tycho” 

Go to “New” → “Function Layer” 

At the dialog select “XisAnalysis” from “Sources”, and from “Layers”, select “Surface 

Roughness”. 

Click “Next” 

At the next dialog, select “LmmpWcsTopography” as the “Source”, and “LOLA_v2” as 

the “Layer”. 

At the next dialog we are presented with parameters. There is an additional parameters 

specified as “Function Parameter A”. If you hover over it, you are presented with what it 

does for this function. The tool tip that appears will say “Roughness Parameter (meters)”. 

This parameter dictates over what distance the mean should be calculated for the 

roughness calculation.  

 

Leave all parameters as is for now, and click “Finish”. 

 

The calculation will be performed, and will yield the result shown below: 
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Unfortunately, the parameters selected for the colormap are too wide for the range in the 

image. If you click on the legend, you can see that the maximum value visible is around 

1000. We will change the color parameters to better render the image. 

 

To redo a calculation with new parameters: 

 

Expand “Image Layers” 

Right click “Surface Roughness (LOLA_v2)”. Select “Properties”. 
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The following dialog will appear: 

 

In the left column there is an item labled “DataRequest”. Follow the row it is in all the 

way to the right, and click the ellipsis button “...” 
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The following dialog will appear: 

Here you can make changes to the original function request.  

 

Change the “Color Map Max” to 1000. 

Click “OK”. 

 

You will notice in the background, ILIADS recolorizing the map. However, before 

closing the properties dialog, we will change one more thing. 

 

In the left column, there is a parameter labeled “Opacity”. This determines how 

transparent the layer is, with 1.0 being completely opaque, and 0 being completely 

transparent. 

 

Change the “Opacity” value to “.5”. 

Click “Close”. 
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The ILIADS display will now appear as depicted below. The Kaguya Terrain Camera 

layer is now visible underneath the surface roughness layer: 
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5 Other Notes, Tips and Tricks 

5.1 Java 

ILIADS requires Java 1.6 (aka, “Java 6”). The easiest way to obtain the latest JRE (Java 

Run-time Environment) is to visit: 

http://www.java.com 

5.2 Intel Graphics Processors 

Some Intel graphics processors do not work properly with ILIADS. This is due to Intel 

not providing a complete implementation of OpenGL 2.0 for these chipsets. Currently, 

the only remedy is to visit the manufacturer's website and try to obtain the latest drivers 

for the graphics chipset. 

5.3 Clearing the ILIADS Cache 

ILIADS caches data it downloads, and retains this cache from session to session. To clear 

the cache, in the menu bar go to “Tools” → “Clear Cache”. 

5.4 Speeding up Traveling 

ILIADS dynamically loads layers and performs calculations on the fly. It will do this on 

all layers that are available and enabled. If there are a lot of layers loaded, this can make 

ILIADS sluggish when traversing the moon, as ILIADS will need to request new pieces 

of data from the server, and perform analysis on any Function Layers.  

To speed ILIADS up, it is possible to suppress this behavior by setting the “Enabled” 

checkbox next to a layer to “OFF”. ILIADS will retain all the settings for that layer, but 

will not fetch new data for it until it is checked to “ON” again.  


